FillFlags Enumeration
Flags indicating whether and how the interiors of closed planar regions is displayed within a view.
Members
Name | Value | Description |
---|---|---|
Always | Use the element's fill color even when fill is disabled in the view's ViewFlags. | |
Background | Use the view's background color instead of the element's fill color. | |
Behind | Render the fill behind other geometry belonging to the same element. For example if an element's geometry contains text with background fill, the text always renders in front of the fill. |
|
Blanking | Combines Behind and Always flags. | |
ByView | Use the element's fill color when fill is enabled in the view's ViewFlags. | |
None | No fill |
Defined in
- core/common/src/GraphicParams.ts Line 18
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.