lerp Method
Create a ColorDef that is the linear interpolation of this ColorDef and another ColorDef, using a weighting factor.
lerp(color2: ColorDef, weight: number): ColorDef
Parameter | Type | Description |
---|---|---|
color2 | ColorDef | The other color |
weight | number | The weighting factor for color2. 0.0 = this color, 1.0 = color2. |
Returns - ColorDef
Defined in
- core/common/src/ColorDef.ts Line 406
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.