describeAvailableEndpoints MethodStatic
Describes the RPC interfaces and endpoints that are currently available from the backend.
describeAvailableEndpoints(): Promise<RpcInterfaceEndpoints[]>
@note Some endpoints may be marked incompatible if the frontend expected a different interface declaration than the backend supplied. RPC operations against an incompatible interface will fail.
Returns - Promise<RpcInterfaceEndpoints[]>
Defined in
- core/common/src/RpcManager.ts Line 64
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.