getLocalizedStringWithNamespace Method
Deprecated in 3.x. Use getLocalizedString
instead; providing either a key with a namespace <namespace>:<key>
or
including { ns: <namespace> }
in the options.
Similar to getLocalizedString
but the namespace is a separate param and the key does not include the namespace.
getLocalizedStringWithNamespace(_namespace: string, key: string | string[]): string
@returns The string corresponding to the first key that resolves.
@throws Error if no keys resolve to a string.
Parameter | Type | Description |
---|---|---|
_namespace | string | |
key | string | string[] | the key that matches a property in the JSON localization file. |
Returns - string
The string corresponding to the first key that resolves.
Defined in
- core/common/src/Localization.ts Line 129
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.