IpcSocketFrontend Interface
Interface for the frontend (browser) side of a socket connection. Frontends may invoke methods implemented on the backend.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
invoke | (channel: string, ...args: any[]) => Promise<any> | Send a message to the backend via channel and expect a result asynchronously. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
addListener | (channel: string, listener: IpcListener) => RemoveFunction | IpcSocket | Establish a handler to receive messages for a channel through a socket. |
removeListener | (channel: string, listener: IpcListener) => void | IpcSocket | Remove a previously registered listener |
send | (channel: string, ...data: any[]) => void | IpcSocket | Send a message over the socket. |
Defined in
- core/common/src/ipc/IpcSocket.ts Line 70
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.