QueryPropertyMetaData Interface
Properties
Name | Type | Description | |
---|---|---|---|
accessString | string | undefined | Access string is the property's alias if the property is a generated one, otherwise it is the ECSQL property path. | |
className | string | The class name is set to empty if the property is a generated one, otherwise, it is the name of the ECClass that the property is contained within. | |
extendType | string | If this property is a PrimitiveECProperty, extend type is the extended type name of this property, if it is not defined locally will be inherited from base property if one exists, otherwise extended type is set to an empty string. | |
generated | boolean | True if the property is a generated one. | |
index | number | The index of the property value if the result is formatted as an array | |
jsonName | string | The JSON name is the property's alias if the property is a generated one, otherwise, it is the ECSQL property path for the system property. | |
name | string | The name is the property's alias if the property is a generated one, otherwise, it is the name of the property. | |
typeName | string | The type name is set to 'navigation' if the property is a navigation property, otherwise, it is the type name for the property. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.