spatialToEcef Method
Convert a point in this iModel's Spatial coordinates to an ECEF point using its ecefLocation.
spatialToEcef(spatial: Readonly<WritableXYAndZ>, result?: Point3d): Point3d
@returns A Point3d in ECEF coordinates
@throws IModelError if isGeoLocated is false.
Parameter | Type | Description |
---|---|---|
spatial | Readonly<WritableXYAndZ> | A point in the iModel's spatial coordinates |
result | Point3d | If defined, use this for output |
Returns - Point3d
A Point3d in ECEF coordinates
Defined in
- core/common/src/IModel.ts Line 648
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.