ecefToSpatial Method
Convert a point in ECEF coordinates to a point in this iModel's Spatial coordinates using its ecefLocation.
ecefToSpatial(ecef: Readonly<WritableXYAndZ>, result?: Point3d): Point3d
@returns A Point3d in this iModel's spatial coordinates
@throws IModelError if isGeoLocated is false.
@note The resultant point will only be meaningful if the ECEF coordinate is close on the earth to the iModel.
Parameter | Type | Description |
---|---|---|
ecef | Readonly<WritableXYAndZ> | A point in ECEF coordinates |
result | Point3d | If defined, use this for output |
Returns - Point3d
A Point3d in this iModel's spatial coordinates
Defined in
- core/common/src/IModel.ts Line 657
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.