BriefcaseIdValue Enumeration
Values of BriefcaseId that have special meaning.
Members
Name |
Value |
Description |
FirstValid |
|
All valid iModelHub issued BriefcaseIds will be equal or higher than this |
Illegal |
|
Indicates an invalid/illegal BriefcaseId |
LastValid |
|
All valid iModelHub issued BriefcaseIds will be equal or lower than this |
Max |
|
BriefcaseIds must be less than this value |
Unassigned |
|
The briefcase has not been assigned a unique Id by iModelHub. Only briefcases that have been assigned a unique BriefcaseId may create changesets, because BriefcaseId is used to create unique ElementIds for new elements.
The Unassigned briefcaseId is used for several purposes: - Snapshots. Snapshot files are immutable copies of an iModel for archival or data exchange purposes. They can neither generate nor accept new changesets. - Checkpoints. Checkpoints are Snapshots that represent a specific version on an iModel's timeline. - PullOnly. A local briefcase file that may be used to "slide" along a timeline by applying incoming changesets. They are always opened readonly except to apply changesets. - Standalone. Standalone iModels are local files that are not connected to iModelHub, and therefore cannot accept or create changesets. |
Defined in
Last Updated: 13 November, 2024