getErrorStack MethodStatic
Use run-time type checking to safely get the call stack of an unknown error value, if possible.
getErrorStack(error: unknown): undefined | string
@note It's recommended to use this function in catch
clauses, where a caught value cannot be assumed to be instanceof Error
Parameter | Type | Description |
---|---|---|
error | unknown |
Returns - undefined | string
Defined in
- core/bentley/lib/cjs/BentleyError.d.ts Line 322
Last Updated: 08 August, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.