BaseReaderOptions Interface
Config for all request made to concurrent query engine.
Properties
Name | Type | Description | |
---|---|---|---|
priority | number | undefined | Determine priority of this query default to 0, used as hint and can be overriden by backend. | |
quota | QueryQuota | undefined | Restrict time or memory for query but use as hint and may be changed base on backend settings | |
restartToken | string | undefined | If specified cancel last query (if any) with same restart token and queue the new query | |
usePrimaryConn | boolean | undefined | For editing apps this can be set to true and all query will run on primary connection |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.