intersectsRay Method
Computes whether a ray intersects these clipping planes.
intersectsRay(origin: Point3d, direction: Vector3d): boolean
@returns true if the ray extending from origin
in the specified direction
intersects at least one of the clipping planes.
Parameter | Type | Description |
---|---|---|
origin | Point3d | The origin of the ray. |
direction | Vector3d | The direction of the ray. |
Returns - boolean
true if the ray extending from origin
in the specified direction
intersects at least one of the clipping planes.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.