containsPoint Method
Determines whether a point is contained within these frustum planes.
containsPoint(point: Point3d, tolerance: number1.0e-8): boolean
@returns true if point
is no further than tolerance
meters outside of the clipping planes.
Parameter | Type | Description |
---|---|---|
point | Point3d | The point to test for containment. |
tolerance | number | The maximum distance from the interior of the frustum planes that will still be considered "contained". |
Returns - boolean
true if point
is no further than tolerance
meters outside of the clipping planes.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.