ExtantElementGeometryChange Interface
Represents the insertion of a new GeometricElement, or a change to the geometric properties of an existing GeometricElement.
@see ElementGeometryChange.
Properties
Name | Type | Description | |
---|---|---|---|
id Readonly | string | The element's Id. | |
range Readonly | Range3d | The element's range. | |
type Readonly | DbOpcode.Insert | DbOpcode.Update | Indicates whether this change resulted from the insertion of a new element or modification of an existing one. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.