ElementGeometryRequest Interface
Parameters for IModelDb.elementGeometryRequest
Properties
Name | Type | Description | |
---|---|---|---|
angleTol | number | undefined | Option for replaceBReps, max angle difference in radians for approximated face, see StrokeOptions | |
chordTol | number | undefined | Option for replaceBReps, max distance from a face to the original geometry, see StrokeOptions | |
elementId | string | The source element for the geometry stream | |
maxEdgeLength | number | undefined | Option for replaceBReps, max length of any edge in generated faces, see StrokeOptions | |
minBRepFeatureSize | number | undefined | Option for replaceBReps, ignore faces with bounding boxes smaller than this size when facetting | |
onGeometry | ElementGeometryFunction | A function to call for the geometry stream data | |
replaceBReps | boolean | undefined | When not omitting BReps, whether to return a mesh or curve representation instead of the brep data | |
skipBReps | boolean | undefined | Whether to omit BRep data |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.