SheetIndexReferenceProps Interface
Properties of a SheetIndexReference
Extends
Properties
Name | Type | Description | |
---|---|---|---|
sheetIndex | RelatedElementProps | undefined | The bis:SheetIndex that this bis:SheetIndexReference is pointing to. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Inherited | string | SheetIndexEntryProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code Inherited | CodeProps | SheetIndexEntryProps | The Code for this element |
entryPriority Inherited | number | SheetIndexEntryProps | Can be used to prioritize or order members within a SheetIndex or SheetIndexFolder. |
federationGuid Inherited | string | undefined | SheetIndexEntryProps | A FederationGuid assigned to this element. |
id Inherited | string | undefined | SheetIndexEntryProps | The Id of the entity. |
isInstanceOfEntity Readonly Inherited | undefined | undefined | SheetIndexEntryProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties Inherited | any | undefined | SheetIndexEntryProps | Optional json properties of this element. |
model Inherited | string | SheetIndexEntryProps | The Id of the Model containing this element |
parent Inherited | RelatedElementProps | undefined | SheetIndexEntryProps | The Parent of this element, if defined. |
userLabel Inherited | string | undefined | SheetIndexEntryProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 607
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.