RepositoryLinkProps Interface
Parameters of a RepositoryLink
Extends
Properties
Name | Type | Description | |
---|---|---|---|
format | string | undefined | ||
repositoryGuid | string | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Inherited | string | UrlLinkProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code Inherited | CodeProps | UrlLinkProps | The Code for this element |
description Inherited | string | undefined | UrlLinkProps | |
federationGuid Inherited | string | undefined | UrlLinkProps | A FederationGuid assigned to this element. |
id Inherited | string | undefined | UrlLinkProps | The Id of the entity. |
isInstanceOfEntity Readonly Inherited | undefined | undefined | UrlLinkProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties Inherited | any | undefined | UrlLinkProps | Optional json properties of this element. |
model Inherited | string | UrlLinkProps | The Id of the Model containing this element |
parent Inherited | RelatedElementProps | undefined | UrlLinkProps | The Parent of this element, if defined. |
url Inherited | string | undefined | UrlLinkProps | |
userLabel Inherited | string | undefined | UrlLinkProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 566
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.