ExternalSourceAttachmentProps Interface
Properties of an ExternalSourceAttachment
Extends
Properties
Name | Type | Description | |
---|---|---|---|
attaches | RelatedElementProps | undefined | ||
pitch | number | undefined | ||
role | ExternalSourceAttachmentRole | undefined | ||
roll | number | undefined | ||
scale | XYZProps | undefined | ||
translation | XYZProps | undefined | ||
yaw | number | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Inherited | string | ElementProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code Inherited | CodeProps | ElementProps | The Code for this element |
federationGuid Inherited | string | undefined | ElementProps | A FederationGuid assigned to this element. |
id Inherited | string | undefined | ElementProps | The Id of the entity. |
isInstanceOfEntity Readonly Inherited | undefined | undefined | ElementProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties Inherited | any | undefined | ElementProps | Optional json properties of this element. |
model Inherited | string | ElementProps | The Id of the Model containing this element |
parent Inherited | RelatedElementProps | undefined | ElementProps | The Parent of this element, if defined. |
userLabel Inherited | string | undefined | ElementProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 484
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.