override Method
Produce a copy of these ViewFlags, overriding some of its properties. Any properties not explicitly specified by overrides
will retain their current values,
as will any property explicitly set to undefined
.
override(overrides: Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>>): ViewFlags
@see copy to have undefined
properties reset to their default values.
Parameter | Type | Description |
---|---|---|
overrides | Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> | The properties to override. |
Returns - ViewFlags
Defined in
- core/common/src/ViewFlags.ts Line 274
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.