DisplayStyleSubCategoryProps Interface
Describes the SubCategoryOverrides applied to a SubCategory by a DisplayStyle.
@see DisplayStyleSettingsProps
Extends
Properties
Name | Type | Description | |
---|---|---|---|
subCategory | string | undefined | The Id of the SubCategory whose appearance is to be overridden. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
color | number | undefined | SubCategoryAppearance.Props | See SubCategoryAppearance.color. |
fill | number | undefined | SubCategoryAppearance.Props | See fillColor. |
invisible | boolean | undefined | SubCategoryAppearance.Props | See invisible. |
material | string | undefined | SubCategoryAppearance.Props | See materialId. |
priority | number | undefined | SubCategoryAppearance.Props | See priority. |
style | string | undefined | SubCategoryAppearance.Props | See styleId. |
transp | number | undefined | SubCategoryAppearance.Props | See transparency. |
transpFill | number | undefined | SubCategoryAppearance.Props | See fillTransparency. |
weight | number | undefined | SubCategoryAppearance.Props | See SubCategoryAppearance.weight. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.