omit Function
A runtime property omitter, makes a shallow copy of the given object without the specified properties
Compatible with the typescript Omit
mapped type:
const testvar: Omit<{x: string, y: object}, "y"> = omit({x: "hello", y: {}}, ["y"]);
omit<T extends object, K extends ReadonlyArray
Parameter | Type | Description |
---|---|---|
t | T | |
keys | K |
Returns - Omit<T, >
Defined in
- core/bentley/src/UtilityTypes.ts Line 128
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.