Id64.Uint32Pair Interface
Represents an Id64 as a pair of unsigned 32-bit integers. Because Javascript lacks efficient support for 64-bit integers, this representation can be useful in performance-sensitive code like the render loop.
@see - getUint32Pair to convert an Id64String to a Uint32Pair.
- fromUint32Pair to convert a Uint32Pair to an Id64String.
- Uint32Set and Uint32Map for collections based on Uint32Pairs.
Properties
Name | Type | Description | |
---|---|---|---|
lower | number | The lower 4 bytes of the 64-bit integer. | |
upper | number | The upper 4 bytes of the 64-bit integer. |
Defined in
- core/bentley/src/Id.ts Line 279
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.