Id64.toIdSet Function
Convert an Id64Arg into an Id64Set.
This method can be used by functions that accept an Id64Arg to conveniently process the value(s). For example:
public addCategories(arg: Id64Arg) { Id64.toIdSet(arg).forEach((id) => this.categories.add(id)); }
Alternatively, to avoid allocating a new Id64Set, use iterable.
toIdSet(arg: Id64Arg, makeCopy: booleanfalse): Id64Set
@returns An Id64Set containing the set of Id64Strings represented by the Id64Arg.
Parameter | Type | Description |
---|---|---|
arg | Id64Arg | The Ids to convert to an Id64Set. |
makeCopy | boolean | If true, and the input is already an Id64Set, returns a deep copy of the input. |
Returns - Id64Set
An Id64Set containing the set of Id64Strings represented by the Id64Arg.
Defined in
- core/bentley/src/Id.ts Line 332
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.