Id64.fromString Function
Given a string value, attempt to normalize it into a well-formed Id string. If the input is already a well-formed Id string, it is returned unmodified. Otherwise, the input is trimmed of leading and trailing whitespace, converted to lowercase, and an attempt is made to parse it as a 64-bit hexadecimal integer. If parsing succeeds the normalized result is returned; otherwise the result is "0", indicating an invalid Id.
For a description of "well-formed", see Working with Ids.
fromString(val: string): Id64String
Parameter | Type | Description |
---|---|---|
val | string |
Returns - Id64String
Defined in
- core/bentley/src/Id.ts Line 112
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.