Id64.fromLocalAndBriefcaseIds Function
Produce an Id string from a local and briefcase Id.
fromLocalAndBriefcaseIds(localId: number, briefcaseId: number): Id64String
@returns an Id64String containing the hexadecimal string representation of the unsigned 64-bit integer which would result from the
operation localId | (briefcaseId << 40)
, or an invalid Id "0" if the inputs are invalid.
Parameter | Type | Description |
---|---|---|
localId | number | The non-zero local Id as an unsigned 40-bit integer. |
briefcaseId | number | The briefcase Id as an unsigned 24-bit integer. |
Returns - Id64String
an Id64String containing the hexadecimal string representation of the unsigned 64-bit integer which would result from the
operation localId | (briefcaseId << 40)
, or an invalid Id "0" if the inputs are invalid.
Defined in
- core/bentley/src/Id.ts Line 160
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.