CompressedId64Set.decompressSet Function

Decompress the compact string representation of an Id64Set into an Id64Set.

decompressSet(compressedIds: string, out?: Id64Set): Id64Set

@returns The set containing the decompressed Ids.

@throws Error if compressedIds is not a well-formed CompressedId64Set.

@see - compressSet to perform the inverse operation.

  • decompressArray to decompress as an Id64Array instead.
  • iterable to efficiently iterate the Ids.
Parameter Type Description
compressedIds string The compact string representation.
out Id64Set If supplied, the Ids will be inserted into this set rather than allocating and returning a new set.

Returns - Id64Set

The set containing the decompressed Ids.

Defined in

Last Updated: 14 November, 2024