CompressedId64Set.decompressArray Function
Decompress the compact string representation of an Id64Set into an Id64Array.
decompressArray(compressedIds: string, out?: Id64Array): Id64Array
@returns The array containing the decompressed Ids.
@throws Error if compressedIds
is not a well-formed CompressedId64Set.
@note The Ids are decompressed and appended to the array in ascending order based on their 64-bit numerical values.
@see - compressArray to perform the inverse operation.
- decompressSet to decompress as an Id64Set instead.
- iterable to efficiently iterate the Ids.
Parameter | Type | Description |
---|---|---|
compressedIds | string | The compact string representation. |
out | Id64Array | If supplied, the Ids will be appended to this array rather than allocating and returning a new array. |
Returns - Id64Array
The array containing the decompressed Ids.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.