CompressedId64Set.compressSet Function

Given a set of Id64Strings, produce a compact string representation. Useful when serializing potentially large sets of Ids.

compressSet(ids: Id64Set): CompressedId64Set

@note Invalid Ids are ignored.

@see - sortAndCompress to compress any unordered collection of Ids.

  • compressArray to perform the same operation on an Id64Array.
  • decompressSet to perform the inverse operation.
Parameter Type Description
ids Id64Set  

Returns - CompressedId64Set

Defined in

Last Updated: 14 November, 2024