UintArrayBuilderOptions Interface
Options used to construct a UintArrayBuilder.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
initialType | Uint8ArrayConstructor | Uint32ArrayConstructor | Uint16ArrayConstructor | The type of the initial empty TypedArray created by the builder. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
growthFactor Inherited | number | undefined | TypedArrayBuilderOptions | Controls how much additional memory is allocated when the TypedArray needs to be resized to accomodate more elements. |
initialCapacity Inherited | number | undefined | TypedArrayBuilderOptions | The number of elements to allocate memory for in the TypedArray when creating the builder. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.