ensureBytesPerElement MethodProtected
Ensures that the underlying array is of a type that can contain the largest value in newValues
.
For example, if _data
is a Uint16Array
and newValues
contains any value(s) larger than 65,535, it will be replaced with a Uint32Array
.
This method is invoked by push and append.
ensureBytesPerElement(newValues: Iterable<number, any, any>): void
Parameter | Type | Description |
---|---|---|
newValues | Iterable<number, any, any> |
Returns - void
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.