lowerBound MethodProtected
Computes the position at which the specified value should be inserted to maintain sorted order.
lowerBound(value: T): { equal: boolean, index: number }
@returns an object with 'index' corresponding to the computed position and 'equal' set to true if an equivalent element already exists at that index.
Parameter | Type | Description |
---|---|---|
value | T | The value whose position is to be computed. |
Returns - { equal: boolean, index: number }
an object with 'index' corresponding to the computed position and 'equal' set to true if an equivalent element already exists at that index.
Defined in
- core/bentley/src/SortedArray.ts Line 208
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.