constructor Method
Construct a new ReadonlyOrderedSet
ReadonlyOrderedSet<T>(compare: OrderedComparator<T>, clone: CloneFunction<T>shallowClone): ReadonlyOrderedSet<T>
Parameter | Type | Description |
---|---|---|
compare | OrderedComparator<T> | The function used to compare elements within the set, determining their ordering. |
clone | CloneFunction<T> | The function invoked to clone a new element for insertion into the set. The default implementation simply returns its input. |
Returns - ReadonlyOrderedSet<T>
Defined in
- core/bentley/src/OrderedSet.ts Line 24
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.