extractArrays Method
Extracts the contents of this dictionary as a pair of { keys, values } arrays, and empties this dictionary. The array of keys is sorted according to the comparison criterion. The position of each value in the array of values corresponds the the position of the corresponding key in the array of keys.
extractArrays(): { keys: K[], values: V[] }
@returns a pair of { keys, values } arrays in which key[i] corresponds to value[i] in this dictionary and the keys are in sorted order.
Returns - { keys: K[], values: V[] }
a pair of { keys, values } arrays in which key[i] corresponds to value[i] in this dictionary and the keys are in sorted order.
Defined in
- core/bentley/src/Dictionary.ts Line 218
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.