constructor Method
Construct a new Dictionary<K, V>.
Dictionary<K, V>(compareKeys: OrderedComparator<K>, cloneKey: CloneFunction<K>shallowClone, cloneValue: CloneFunction<V>shallowClone): Dictionary<K, V>
Parameter | Type | Description |
---|---|---|
compareKeys | OrderedComparator<K> | The function used to compare keys within the dictionary. |
cloneKey | CloneFunction<K> | The function invoked to clone a key for insertion into the dictionary. The default implementation simply returns its input. |
cloneValue | CloneFunction<V> | The function invoked to clone a value for insertion into the dictionary. The default implementation simply returns its input. |
Returns - Dictionary<K, V>
Defined in
- core/bentley/src/Dictionary.ts Line 76
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.