WorkspaceDbProps Interface

Properties that specify how to load a WorkspaceDb within a WorkspaceContainer.

Extends

Properties

Name Type Description
includePrerelease Readonly boolean | undefined If true, allow semver prerelease versions, e.g., "1.4.2-beta.0".  
prefetch Readonly boolean | undefined If true, start a prefetch operation whenever this WorkspaceDb is opened, to begin downloading pages of the database before they are needed.  

Inherited properties

Name Type Inherited from Description
dbName Readonly Inherited string | undefined WorkspaceDbNameAndVersion The name of the WorkspaceDb.
version Readonly Inherited string | undefined WorkspaceDbNameAndVersion The range of acceptable versions of the WorkspaceDb of the specified dbName.

Defined in

Last Updated: 14 November, 2024