Setting.areEqual Function
Returns true if a
and b
are considered equivalent Setting values.
Settings of primitive types like number
and string
are compared using ===
.
Settings of type "object" are compared by comparing each property using areEqual
; the objects are considered
equal if they have the exact same set of property names with equivalent values.
Settings of type "array" are compared by comparing each element of the arrays use areEqual
; the arrays are considered
equal if they have the same number of elements with equivalent values in the same exact order.
areEqual(a: JSONSchemaType, b: JSONSchemaType): boolean
Parameter | Type | Description |
---|---|---|
a | JSONSchemaType | |
b | JSONSchemaType |
Returns - boolean
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.