QueryWorkspaceResourcesArgs Interface
Arguments supplied to queryResources defining the query criteria and the list of WorkspaceDbs to query.
Properties
Name | Type | Description | |
---|---|---|---|
callback | QueryWorkspaceResourcesCallback | A function invoked to process the resources that match the query criteria. | |
dbs | WorkspaceDb[] | The list of WorkspaceDb s to query, in the order in which they are to be queried. |
|
nameCompare | "GLOB" | "LIKE" | "NOT GLOB" | "NOT LIKE" | "=" | "<" | ">" | The comparison operator by which to compare the name of each resource to namePattern. | |
namePattern | string | undefined | A pattern against which to compare the name of each resource, using nameCompare as the comparison operator. | |
type | "string" | "blob" | The type of resource to query. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.