deleteView Method
Delete a view from a ViewStore. If this is the default view for a view group, it cannot be deleted until another view is set as the default.
deleteView(arg: { viewId: RowIdOrString }): Promise<void>
@note If this view references a category selector, model selector, or display style that is not referenced by any other view, and do not have a name, they will each also be deleted. If the view has a thumbnail, it is also deleted.
Parameter | Type | Description |
---|---|---|
arg | { viewId: RowIdOrString } |
Returns - Promise
Defined in
- core/backend/src/ViewStore.ts Line 1341
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.