addOrReplaceThumbnail Method
Add a thumbnail for a view. If the view already has a thumbnail, it is replaced. If a view is deleted, its thumbnail is also deleted.
addOrReplaceThumbnail(args: { owner?: string, thumbnail: ThumbnailProps, viewId: RowIdOrString }): Promise<void>
@note The thumbnail must be a valid image in PNG or JPEG format.
Parameter | Type | Description |
---|---|---|
args | { owner?: string, thumbnail: ThumbnailProps, viewId: RowIdOrString } |
Returns - Promise
Defined in
- core/backend/src/ViewStore.ts Line 1144
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.