setRequiredVersions Method
Change the "versions required to open this database" property stored in this database. After this call, versions of software that don't meet the supplied ranges will fail.
setRequiredVersions(versions: SQLiteDb.RequiredVersionRanges): void
@note the database must be opened for write access.
Parameter | Type | Description |
---|---|---|
versions | SQLiteDb.RequiredVersionRanges | the new versions required for reading and writing this database. |
Returns - void
Defined in
- core/backend/src/SQLiteDb.ts Line 297
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.