getObject Method
Overloads | |
---|---|
getObject(name) | |
getObject(name, defaultValue) |
getObject(name)
Get the value of an object property by name.
getObject(name: string): undefined | SettingsContainer
@returns the property's value if it exists and is an object, undefined
otherwise.
Parameter | Type | Description |
---|---|---|
name | string |
Returns - undefined | SettingsContainer
the property's value if it exists and is an object, undefined
otherwise.
getObject(name, defaultValue)
Get the value of an object property by name.
getObject(name: string, defaultValue: SettingsContainer): SettingsContainer
@returns the property's value if it exists and is an object, otherwise the supplied default value.
Parameter | Type | Description |
---|---|---|
name | string | |
defaultValue | SettingsContainer |
Returns - SettingsContainer
the property's value if it exists and is an object, otherwise the supplied default value.
Defined in
- core/backend/src/PropertyStore.ts Line 125
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.