CloudSqlite.uploadDb Function
Upload a local SQLite database file into a CloudContainer.
uploadDb(container: CloudSqlite.CloudContainer, props: CloudSqlite.TransferDbProps): Promise<void>
@note this function requires that the write lock be held on the container
Parameter | Type | Description |
---|---|---|
container | CloudSqlite.CloudContainer | the CloudContainer holding the database. Must be connected. |
props | CloudSqlite.TransferDbProps | the properties that describe the database to be downloaded, plus optionally an onProgress function. |
Returns - Promise
Defined in
- core/backend/src/CloudSqlite.ts Line 662
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.