CloudSqlite.ObtainLockParams Interface
Parameters used to obtain the write lock on a cloud container
Properties
Name | Type | Description | |
---|---|---|---|
nRetries | number | number of times to retry in the event the lock currently held by someone else. | |
onFailure | CloudSqlite.WriteLockBusyHandler | undefined | function called if lock cannot be obtained after all retries. | |
retryDelayMs | number | Delay between retries, in milliseconds. | |
user | string | undefined | a string that identifies me to others if I hold the lock while they attempt to acquire it. |
Defined in
- core/backend/src/CloudSqlite.ts Line 266
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.