CloudSqlite.downloadDb Function
Download a database from a CloudContainer.
downloadDb(container: CloudSqlite.CloudContainer, props: CloudSqlite.TransferDbProps): Promise<void>
@returns a Promise that is resolved when the download completes.
@note the download is "restartable." If the transfer is aborted and then re-requested, it will continue from where it left off rather than re-downloading the entire file.
Parameter | Type | Description |
---|---|---|
container | CloudSqlite.CloudContainer | the CloudContainer holding the database. Must be connected. |
props | CloudSqlite.TransferDbProps | the properties that describe the database to be downloaded, plus optionally an onProgress function. |
Returns - Promise
a Promise that is resolved when the download completes.
Defined in
- core/backend/src/CloudSqlite.ts Line 674
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.