writeLocker
GetterReadOnly
A Proxy Object to call a writeable async method on the cloud database controlled by this DbAccess
.
Whenever a method is called through this Proxy, it will:
- attempt to acquire the write lock on the container
- open the database for write
- call the method
- close the database
- upload changes
- release the write lock.
writeLocker: PickAsyncMethods<WriteMethods>
@see CloudSqlite.DbAccess.withLockedDb
Returns - PickAsyncMethods<WriteMethods>
Defined in
- core/backend/src/CloudSqlite.ts Line 1012
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.