CloudSqlite.CloudPrefetch Interface
Object returned by startCloudPrefetch. It holds a promise that is fulfilled when a Prefetch is completed. May also be used to cancel an in-progress prefetch.
Methods
Name | Description | |
---|---|---|
cancel(): void | Cancel a currently pending prefetch. |
Properties
Name | Type | Description | |
---|---|---|---|
cloudContainer Readonly | CloudSqlite.CloudContainer | ||
dbName Readonly | string | ||
promise | Promise<boolean> | Promise that is resolved when the prefetch completes or is cancelled. |
Defined in
- core/backend/src/CloudSqlite.ts Line 566
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.