CloudSqlite.CachedDbProps Interface
Returned from CloudContainer.queryDatabase
describing one database in the container
Properties
Name | Type | Description | |
---|---|---|---|
dirtyBlocks Readonly | number | the number of blocks from this database that have been modified in the CloudCache and need to be uploaded. | |
localBlocks Readonly | number | the number of blocks of the database that have been downloaded into the CloudCache | |
nClient Readonly | number | current number of clients that have this database open. | |
nPrefetch Readonly | number | current number of ongoing prefetches on this database. | |
state Readonly | "" | "copied" | "deleted" | the state of this database. | |
totalBlocks Readonly | number | The total number of blocks in the database. | |
transactions Readonly | boolean | If true, the database currently has transactions in the WAL file and may not be uploaded until they have been checkPointed. |
Defined in
- core/backend/src/CloudSqlite.ts Line 138
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.