step Method
Step this statement to the next row.
For SQL SELECT statements the method returns
- DbResult.BE_SQLITE_ROW if the statement now points successfully to the next row.
- DbResult.BE_SQLITE_DONE if the statement has no more rows.
- Error status in case of errors.
For SQL INSERT, UPDATE, DELETE statements the method returns
- DbResult.BE_SQLITE_DONE if the statement has been executed successfully.
- Error status in case of errors.
step(): DbResult
Returns - DbResult
Defined in
- core/backend/src/SqliteStatement.ts Line 345
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.