nextRow Method
Call step
on this statement and determine whether a new row is available.
Use this method only when this statement has been prepared with a SELECT statement.
nextRow(): boolean
@returns true if a new row is available, false otherwise.
@throws if step
returns anything other than BE_SQLITE_ROW or BE_SQLITE_DONE.
Returns - boolean
true if a new row is available, false otherwise.
Defined in
- core/backend/src/SqliteStatement.ts Line 113
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.