onRootChanged MethodStatic
Callback invoked by saveChanges on an ElementDrivesElement relationship when its input has changed or is the output of some upstream relationship whose input has changed. This callback is invoked after the input element has been processed by upstream relationships. A subclass of ElementDrivesElement can re-implement this static method to take some action. onRootChanged may modify the output element only.
onRootChanged(_props: RelationshipProps, _iModel: IModelDb): void
Parameter | Type | Description |
---|---|---|
_props | RelationshipProps | The ElementDrivesElement relationship instance. |
_iModel | IModelDb | The iModel |
Returns - void
Defined in
- core/backend/src/Relationship.ts Line 46
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.